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MindMap

Welcome to
ConceptDraw MINDMAP

Computer Systems Odessa Corporation present you ConceptDraw MINDMAP
— a powerful application for for creating clear and visual MindMaps Mac and
PC platforms.

Visual Thinking and MindMapping

Itis known that visual thinking is inherent and natural to human mind. That is
why visual form is most effective for representing information of any sort: it
provides clarity, facilitates perception and understanding, gives general view
which is especially important in planning, developing ideas and projects, stud-
ying complex material. Information in visual form is easier to remember, and
effective to present and explain to others.

MindMapping is a technique for representing and organizing ideas and items
of information in visual form. It helps you express your ideas in an easy way
and organize them one after another in the form of a tree. It reflects the natu-
ral mode of thinking:

1) the main topic is put in the center,

2) thenitis developed in the branch topics,

3) which in their turn are further developed in the subtopics which

are put as sub-branches.

In the sub-branches, the topic is divided into parts, specified and presented in
more detail. Sub-branches can also hold additional information, or some ide-
as formed by association.
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Moreover, there are conventional graphical signs which can be added to the
topics to evaluate the ideas or show the attributes of the topics.

This results in a clear graphical representation of the ideas (or items of informa-
tion) and relations between them in the form of a MindMap. In the MindMap you
can also reinforce the ideas by using graphics, colors, figures and connections.

The main advantage of MindMaps, in comparison with ordinary lists and ta-
bles, is that a MindMap provides a view of the whole. You see the entire
structure of the topic presented — this leads to better understanding, and you
can discover new ideas and approaches.

ConceptDraw MINDMAP is a powerful and easy-to-use tool for MindMap-
ping. Its advanced features will help you quickly organize your ideas and struc-
ture your concepts, plans, daily work, learning material and other information.
This application makes work and learning more effective and facilitates idea
generation.

What You Benefit from ConceptDraw
MINDMAP

ConceptDraw MINDMAP combines the power of two technologies:
— the MindMapping technique which helps dividing the problem
into several simpler parts and solve them effectively,
— and the ConceptDraw technology which helps you visualize the
thinking process, and makes it easy to modify and develop the
ideas and share them with others easily via the Internet.

ConceptDraw MINDMAP is effective and helpful in any tasks when you need to
— generate, organize and evaluate ideas,
— structure some information,
— put some concepts in a clear and attractive way to persuade
others.

So it proves helpful as a powerful and easy-to use tool for many purposes:

d- Planning d- Brainstorming

d- Teaching d- Decision-making

d- Organizing d- Presentations

0- Note-taking d- Summaries

d- Outlining d- Project Management
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With ConceptDraw MINDMAP you can

— present processes, ideas, complicated relationships graphically
—in printed way or on the Internet,

— visualize and analyse different factors in daily business decisions,

— facilitate the idea generation in the most creative mode of think-
ing — you allow ideas to flow freely before starting to organize
them,

— present your learning material in a logical and structured way to
understand and remember it better,

— create clear, appealing and persuasive MindMaps which make
your work or studies more effective,

— visualize and structure the plans or ideas to help others working
on a project understand it and to encourage creativity of their own.

Registration
To become a registered user, fill out the registration form on our Web site:

http://www.conceptdraw.com/registration

Registration gives you the following benefits:
d- Unlimited free technical support,
d- Free maintenance;
d- E-mail notification about updates, new libraries and other
components, events and special offers,
d- Discounts for upgrades and other products of ConceptDraw line.

Don't forget to register your copy and subscribe to our e-mail newsletter!

Qubscribing to Newsdletter

Subscribe to our e-mail newsletter to be timely informed about all Concept-
Draw-related news. To do it, just go to our web site

www.conceptdraw.com

and enter your e-mail address in the box at the bottom area of any page.

Once your address is submitted, you'll start to receive our newsletter with
information about updates, new products, new libraries and other useful down-
loads, special offers and events, and other useful information related the Con-
ceptDraw world.
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Downloading Updates

You can download updates from our web site

www.conceptdraw.com.

The fastest way to to check for updates for your product is to choose Get
Latest Update from the Help menu in ConceptDraw MINDMAP. You'll be tak-
en straight to a Web page, containing a link to the update, corresponding to
your platform and interface language. Click on the link to download the file.
Once it's downloaded, run the installer to update ConceptDraw.

Attention! Don't forget to quit ConceptDraw before installing the update.

Technical Qupport

We offer unlimited free technical support by e-mail to our registered users.
See the Registration section on how to register.

To send us a problem report or feature request, fill out the contact from in the
Support section on our Web site.

Replies are normally sent within one business day. We are always happy to
answer your questions and hear your feedback.
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Quick Sart

The brief guide to ConceptDraw MINDMAP will help you to start your work
easily and quickly. You will learn the major features and functionality of the
program by creating several simple mind maps. The topics of the mind maps
were selected to cover the main areas of application of the program.

Lesson 1. Amind map that describesthe
idea of Mind Mapping

Assistant. Adding topics. Sand-alone objects.
Symbols. Syles

Mind Maps are perfect for creating clear, illustrative learning and training mate-
rial. Thanks to this, we can use mind maps to explain the basics of working with
ConceptDraw MINDMAP.

Let’s start learning the application by drawing a mind maps that illustrates the
technique of creating mind maps.

As can be seen from the illustration, a mind map is a hierarchical diagram
formed around a central idea (theme).

The Central Theme is surrounded by branches, which represent the Main Topics
of the diagram, and make up the central theme.

Each main topic can be further detailed by Subtopics, located in the lower
level of the hierarchy. Other means, such as symbols, pictures, colors, text
styles help to attract more attention and aid memory.
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< Ineas, associated with main
f\ topic )

Enter main topic

« i the main idea |

Central Theme

here
""""""" Use symbols
to comment
R . N ideas
Y @] él Ereter main topic

Enter subtopic

Enter main topic Enter subtopic

Enter subtopic

Let’s create a mind map from scratch. When you launch the application, the
start dialog offers several ways to begin your work.

ConceptDraw. MINDMAP Professional |z|

ConceptDrow

MINOWA

third edition

{0

‘ New blank document
i New document with brainstorming

Create a mind map with the Assistant

Create a mind map based on a Template

Open existing mind map

Open last edited mind map

Don'l show this dialog again D

2001-2004@8Capyright by Compuler Syalems Oduass Corp. All righta reasrvad
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We'll use the Assistant for our first mind map. The Assistant helps to create
the structure of the mind map — choose the central theme, main topics and set

the general appearance. To run the Assistant, choose the “Create a mind map
with the Assistant” menu item.

You can also call Assistant from the File ->
New -> Assistant ... menu.
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The Assistant contains three steps. At Step One you enter the titles and choose
an image for the central theme. Let’s select an image from the “Titles” set and
enter “Central Theme” as the name of the main idea.

Click “Next” to proceed to Step Two. At this step you can enter the main topics
of the mind map. Type main topics in the box at the top and click the “Add topic
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to list” button to add it to the map. Let’s create two topics with the same text —
“Enter main topic”.

MindMap Assistant: Step2

Specify the main topics to surround the central theme:

Add topic to izt

Mait bopics:

Enter mzin topic
Enter main topic

«Choose branch slyle Remove topic

< Back | Mext > | Cancel J Help J

At the last step you choose the style and arrangement of mind map branches.
Leave the default “Curved” option and click “Finish” to quit Assistant. The fol-
lowing document will be created:

Enter main topic Central Theme Enter main topic

It's comprised of the object that represents the central theme and two branch-
es. So far it hardly resembles the final result. To reproduce the needed struc-
ture, one more main topic and three subtopics are missing.

10




Lesson 1

P To add one more main topic, click an existing
1 topic to select it and use the Add Topic
toolbar button.

New Branchl E Enter main topic j

When a topic is added, it's named “New Branch” by default and its text re-
mains selected so you can edit it right away. Rename it to “Enter main topic”.
To quit the edit mode, click outside the branch. Note how the branch is resized
automatically to fully accommodate the text.

Gt To add a subtopic below a topic (its parent),
Ehm select the parent topic and click the Add
Subtopic toolbar button.

Enter subtapic Enter main topic m Enter main topic
Erter subtopic Enter main topic )—J

Enter subtopic

Now we have the structure. But the resulting diagram looks quite humble com-
pared to the one in the beginning of this lesson. We need something to reme-
dy the situation.

First, let's rearrange the branches. The Arrange button on the tool- ki
bar contains a number of arrange options for the mind map. We’'ll Fid
use the arrangement with all branches to the right from the central
theme.

Automatic arrangement may not always position the branches
exactly as you wish. In our case we need to clear the space for a
callout for the central theme. ConceptDraw MINDMAP allows to
reposition individual branches. Drag a branch with the mouse
and move to a new place. All its sub-branches will move with it.
Move the branches apart to clear some space near the central
theme.

I

o WA KK

11
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Central Theme

Enter main topic

Enter main topic

Erter subtopic
Enter maintopic. .~ Enter subtopic

aseEr'lter subtopic

ConceptDraw MINDMAP lets you use additional elements to code the topics
with special meaning. You can draw your own objects with the built-in drawing
tools, use pre-drawn shapes from the ConceptDraw libraries, insert pictures
from the files on the disk, or OLE objects (Windows version only).

We need to draw a rectangle with the “Select and type the main idea here”
comment and an arrow pointing to the central theme. We'll use the drawing
tools to create the rectangle, and the arrow can be taken from the supplied

libraries.

Certral Theme

Enter main topic

f-—---- e |
o o
[ — R a|

Enter main topic
Enter subtopic

Enter main to pic Enter subtonic

Enter subtopic

L]

-

Use the Rectangle tool on the Drawing Tool
toolbar (to the bottom of the document
window) to draw the rectangle.

Click where you want the rectangle to appear, hold down the mouse button
and drag to draw the rectangle. Select the rectangle (click on it so it displays

green handles).

12
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Enter the text. If needed, adjust the shape and the position of the rectangle by
dragging the handles.

For the arrow we'll take a pre-drawn shape from a library.

A ConceptDraw library is a file with the .cdl extension, that contains a selec-
tion of shapes you can use in drawings. As a rule, shapes in a library cover a
certain topic.

Quite often they have intelligent, formula-controlled behavior.

[ ] ConceptDraw MINDMAP Professional - [Concept!

|:| File: Edit ‘ew Insert Faormat Figure  Library
DeH Sk xb2a an g

|E Connectors

Central Theme

. Click the Open Library ... toolbar button and
ﬁ choose the Connectors.cdl file from the
Connectors&Callouts folder.

The library window will appear in the left part of the document window. Each
icon represents a shape. Choose Flexi-Arrow 1 and drag it from the library
into the document. If needed, adjust its position and size with the help of the
handles.

f . Such shape can be drawn manually with the
Line tool, but it's faster to use a ready-made
library shape.

13
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Central Theme

Enter main topic

Select and
type the main
idea here

=

Enter main topic

Enter subtopic

Enter main topic Enter subtopic

Enter subtopic

The Line tool is in the same button menu as
the Rectangle tool.

Another tool there is Ellipse, which we’ll need
a bit later.

Objects such as a rectangl
document. The drawback is,
tral theme or branches are

e and arrow help to add visual interest to the
however, that they’ll stay in place when the cen-
repositioned, thus making a mess of the neat

mind map. To avoid this, ConceptDraw MINDMAP allows to attach objects

to branches.

Create a comment to the upper branch of the mind map — this time we’ll place
it inside an ellipse and attach to the branch.

[l

Use the Ellipse tool to draw the ellipse, and
type the text of the comment in it.

To attach the ellipse to the b

ranch, move it over the branch until you see the

red border around it and then release the mouse button.

-0

[Enter main topid

deds, asso
AL
o o

— o
ciated with deas, associated with

main topic

e
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When you select an attached object, you can see the green dashed line that
goes from it to the branch it’s tied to. Now, if we move the branch, thee comment
will move with it. Make the similar steps to attach the arrow to the upper branch.

Another way to make the diagram more informative and easy to remember is
to use the symbols. Symbols are small icons that can be added to branches.

I T i T T A e i A Noln

[« %

deas, associated with
e
Enter main topic ' 70

main tapic
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Use them to attract attention, express emotion, set priority of the topic. Once
a symbol is added, you can hover over it to see its meaning. The symbol panel
is located to the right of the application window.

Let's add a few symbols to the middle branch. To do this, select the branch
and click on the desired symbol icons on the symbol panel. When a branch is
selected, the associated symbols are also selected on the symbol panel. To
remove a symbol from the branch, select the branch and click again on the
symbol’s icon on the panel.

Let's add a comment to this branch, too. We will use the 2-D word balloon from
the Callouts.cdl library in the Connectors&Callouts folder, and enter the text
manually.

In fact, all the needed elements of the mind map are in place. To attract more
attention, we can also use colors and fonts. The formatting toolbar at the bot-
tom of the application window contains tools for working with shape and text
style attributes.

16
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To apply formatting to an object or a group of objects, select them and click on
the respective tool on the toolbar.

Lets begin with fonts. Make the central theme text bigger and more eye-
catching.

To do this, change the font first. Select the central theme, choose the Times
New Roman font from the Font Names list on the formatting toolbar, and set
the font size to 20 points in the Font Sizes list.

Text formatting can be applied both to a single object and several selected
objects.

To select more than one object (for instance, if you want all main topics to
have the same font), click them with the Shift key held down. In our case we
use the Monotype Coursiva font, 16 point size for main topics.

We'll use various fonts for different objects, and the same font for similar ob-
jects — such as subtopics of a topic. If needed, adjust the object sizes to look
best for the selected font and font size.

Now we can modify the style attributes of the objects and branches.

17
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i

18

Use the Fill Color toolbar button to fill the arrows with color — blue for
the top arrow, red — for the bottom one. The button contains a drop-
down menu with main colors.

For the objects that contain our comments we’ll change the line color
rather than the fill color. Use the Line Color toolbar button for this. Use
the same colors — blue for the comment inside the ellipse, and red for
the comment near the central theme. For the third comment use green
color.

To change line style to dashed for the two upper comments, choose the
third item of the Styles of Line toolbar button menu.
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There are more visual enhancements to play with:

Add a blue shadow to the ellipse. Use the Fill
Shadow Styles toolbar button to apply the
shadow and choose its color.

Increase the line width of the
comment to the central
theme: select width 4 from
the Line Width toolbar
button menu.

Change the text attributes in the bottom
comment. Make the text color same as the line
color (use the Text Color tool for this), and
make it bold (use the Bold button).

Now we have the mind map that we were going to draw.

19
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So, your first mind map is ready.

To print it, press the Print button on toolbar or
choose the File -> Print menu command or
press

Ctrl+P Cmd+P

To save your mind map, press the Save button
on toolbar or choose the File -> Save menu
command or press

Ctrl+S Cmd+S

To close the map, choose the File -> Close
menu command or press

Ctrl+F4 Cmd+W

To open the saved map, call the Open File
dialog, button or File -> Open menu
command) or press

Ctrl+O Cmd+O

U You can export a map to different file formats and use it in other
applications, such as graphic formats (*.bmp, *.gif, *.emf), PDF and
PowerPoint file format to prepare presentations. Choose any format in
the File -> Export menu.

U You can import different file formats into ConceptDraw MINDMAP to
use in your maps (File -> Import menu).

The bottom line

U ConceptDraw MINDMAP is perfect for drawing well-structured, clear
and nice-looking training and learning materials.

20
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U The Assistant helps to jot down the skeleton of the mind map: specify
the central idea, the main topics that make up the central idea and set
general appearance.

U The toolbar allows to change the structure of the mind map — add or
remove branches at any level of the hierarchy.

U You can use images and illustrations to clarify the diagram and make it
more visual.

U You can draw pictures yourself with the built-in drawing tools, or use
the pre-drawn library shapes.

U Objects can be easily attached to the branches of a mind map.

U The orientation of the branches on the mind map can be changed. You
can choose one of the standard automatic arrangements, or reposition
any object manually.

U Use symbols to code the meaning of the branches to attract attention
or aid remembering.

U You can change the style attributes of objects: line and fill color, line
pattern, text font, size and color.

Lesson 2. Business Plan

Branch Wizard. Legend. Text Notes.
Changing the style of the mind map.
Changing the level of detail of branches

Our next step in learning ConceptDraw MINDMAP will be creating a busi-
ness plan in the form of a mind map. The business plan will describe the
process of organizing Internet sales.

This time we won't use Assistant and will start drawing from scratch.

In the Start dialog, choose New Blank Document, or select the File -> New
-> Document command. In spite of the name, the document is not completely
blank — the central theme is added to the document automatically.

21
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Rename it to “My Business Plan”.

There are many ways to increase Internet sales. That means that our mind
map will contain many main topics and even more subtopics.

If we follow the way we used in the previous lesson —that is, add branches by
using the Add Topic or Add Subtopic buttons, type text, quit the text edit
mode. This way is slow and ineffective for many branches.

To speed it up, use the Branch Wizard. This dialog allows to quickly navigate
between the levels of the mind map tree, add and remove branches.

Select the central theme and click the
Branch Wizard toolbar button (Branch
Wizard starts working from the selected
object).

The dialog window will come up. The top field of the dialog contains the text of
the selected object (“My Business Plan” central theme in our case). First, add
the main topics:

d- advertisements d- search engines

22
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d- link exchange d- writing articles
d0- newsletter o- affiliate programs
d0- website

For each topic type its text in the New Topic field and press Enter. The topic
will be added to the list and appear as a branch on the mind map.

Once we're through with the main topics, let's proceed to the subtopics. For
instance, we want to detail the advertisements topic. Double-click this item in
the list. Now advertisements will appear in the Active Level field. All branch-
es that we add to the list will be child topics to advertisements. Add four sub-
topics: banner ads, ad swap, free ads and magazine ads.

Then add new subtopics to the link exchange topic. First we need to make it
active. Go up to the mind map root by clicking the button , or selecting My

23
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Business Plan from the top list. The lower list will display the child branches of
My Business Plan. Double-click link exchange to make it active. It will display
in the top field, and now you can add subtopics to it as shown above.

Repeat the following for other branches of the mind map to complete the struc-
ture.

Once the structure is complete, it lets us see the big picture of the task. Con-
tinue working with the outlined ideas. Start by adding symbols. They help to
show the attitude to the ideas, assign priorities, add visual comments. In our
case, assume that search engine listing and writing articles are the highest
priorities. Mark them with the ~ symbol.

To mark a branch with a symbol, select the
branch and click on the needed symbol on the
symbol panel.

The task of the least priority — paid advertisement — mark with the ~ symbol.
Other important notes: the time we can spend on creating the web site is
limited , magazine advertisement is expensive , and choosing the right
keywords for each specific search engine is the work that needs additional
research

As it has been mentioned, the meanings of the symbols can be seen on the
floating tips. But sometimes it’s convenient to see them right on the map —
especially if you want to give someone the printout. In ConceptDraw MIND-

24
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MAP you can do this with one click of the mouse. Just select the Insert ->
Legend menu command.

To make the mind map more illustrative, add to the branches images illustrat-
ing each of the associated activities. These images can be found in the sup-

plied libraries — CentralTheme2.cdl (in the MindMapping folder) and
Gestures.cdl (the ArtWork folder).

25




MindMap

Sometimes the supplied symbols or library shape may be not enough. Then
you can create your own picture with a comment, as shown in Lesson 1.

Sometimes you may need to assign a comment to a branch, but don’t want to
have it on the map to avoid clutter. Use text notes for this.

If a branch has a text comment assigned to it, it displays the text comment
symbol . The text of the comment can be seen when you hover the mouse
over it.

To add a text note to a branch, select it and
click the Edit Text Note button.

The Edit Text Note window will open at the bottom of the document window.
Type the text of the comment in it.

26
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The result:

Apart from symbols, objects, images and text notes, you can associate hyper-
links with branches. The hyperlink can link the branch with a file on your compu-
ter, in the local network or with any web page. In ConceptDraw MINDMAP
Professional you can even specify a page within the document to which to
jump on clicking the hyperlink (in the Standard version you can'tlink to a page).

Let's connect the keywords on google branch with the http://iwww.google.com web
site. To do this, select the branch and choose the Format -> Hyperlink -> Edit
menu command. The Hyperlink dialog will open. The branch doesn’t have any
assigned hyperlinks so far, that’s why the No Hyperlink option is currently active.
Select the Internet option and type the above address into the FILE/URL field.

27
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An icon will be added to the branch which the user may click to go to the
homepage of the Google search engine.

Now it's time to think about the appearance of the mind map. Change the look
of the central theme and branches. To change the central theme image, select
it and choose the Change Central Theme Image... command from the con-
text menu. The Central Theme dialog will open.

In the dialog, choose the image
you like. You can choose from
the image sets in the Topical set
list, or use some other picture.
For instance, if you have a
graphic file you'd like to use,
use the Select an image from
another source button to
choose it.

28
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To change the look of the branches,
use the Change Map Style button.
From the button pull-down choose, for
instance, Straight. On the illustration
below, the text of the central theme is
located above the central theme
image. To change the position of the
text, use the green control handle with
the “Reposition Text” pop-up tip.

You can change the appearance of individual branches as well. Select the
branch, open the context menu and select the needed item in the Change
Branch Form submenu.

Besides, you can change the style attributes of branches (color, line and fill
patterns, etc.) as for any other object (see Lesson 1).

If you use this mind map to explain your ideas to other people, you may dis-
play the branches as your thoughts go. For instance, first concentrate the at-
tention of the audience on the main topics (Level 1 branches), and then detail
these topics.

In ConceptDraw MINDMAP you can use the
Show/Hide Branch levels button to change
the detail level of the mind map.

29
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For example, choose Level 1 from the button pull-down. The appearance of
the mind map will change.

To see all levels of the mind map, select All.

The bottom line:

U ConceptDraw MINDMAP is perfect for planning: structuring, developing
and explaining business ideas.

U You can create a mind map manually, without using Assistant
U Use Branch Wizard to add branches faster.

U The legend can be used to show the meaning of the symbols on the
mind map.

U You can assign text notes to branches and the central theme.

U The central theme and branches can have hyperlinks, associated with
them.

U You can change the appearance of the central theme image and branches.
It's possible to modify individual branches, or all the branches at once.

U ConceptDraw MINDMAP allows to change the detail level of the map
and display branches up to the specified level.

30
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Lesson 3. Conference Report

Sorting. Format Map. Multiple Pages

We continue to describe the multitude of applications of ConceptDraw MIND-
MAP. This time we’ll create a mind map that represents a report about the
conference, devoted to our product ConceptDraw. On the example of this
report we'll examine two important features of the application: sorting and
support for multiple pages.

Create (for instance, using Branch Wizard) a mind map of the following struc-
ture.

Working with Branch Wizard is described in
detail in Lesson 2.

We'll use the numeric symbols to indicate the order in which the events happened.

To make it easier to perceive the order of events, rearrange the mind map so
that all branches are to the right of the central theme.

As in Lesson 1, use the Arrange tool for
rearranging.

31
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As you can see, automatic arrangement placed the branches in an order other
than the events happened: number 2 is followed by number 4 instead of 3. Of
course, you can reposition the branches manually. It's not a problem when there
are just two branches to move, but if there are more, it's not an easy task. Con-
ceptDraw MINDMAP allows to sort the branches automatically.

Use the Sort Branches... tool for sorting.

On clicking the Sort Branches... button, a dialog with the same name will
come up, where you can select the sorting mode. Here you can also specify
whether to sort only the main branches, or all branches. Use the Sort only
main branches box for this. Any mind map can be sorted alphabetically (op-
tions By Name (A to Z) and By Name (Z to A)).

If the branches have the priority symbols , and , attached to them, you
can sort the mind map by priority (the By Priority Level option). Branches
with numeric symbols, as in our case, can be sorted by number (the By Number
option).

32
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Our mind map sorted by numbers, will look as follows:

Let's make it more attractive: change the central theme image and attach ap-
propriate pictures to the branches (we’ll use library shapes from the Flags.cdl
library in the Geo Maps folder, and ChartingFigures.cdl library in the Busi-
ness Diagram folder).

See Lesson 1 for details about using library
shapes and attaching objects to branches,

33
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see Lesson 2 — on how to change the central
theme image.

Change the style of the mind map as well. In Lesson 2 we were using the
Change Map Style button for it. Now we’ll use the Format Map dialog, which
offers much more options.

To call it, click the Format Map toolbar button.

This dialog allows to modify the style attributes separately for the main branches
and sub-branches. To switch between these two branch types, use the drop-
down list at the top of the dialog. Let's begin with the main topics. First, make
them thick and straight. In the list at the bottom, choose the Straight Wide
style. Then choose the branch color. We'll fill them with a gradient color, which
gradually changes from gray to white. The branch fill color can be set in the
Fill section of the dialog. To set the foreground fill color, click on the Fore-
ground button. The Choose Color window will appear. Choose the gray color
from the palette. Then click on the Background button and choose the white
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color as the gradient fill background. In the Pattern list choose a gradient
pattern under number 52.

For sub-branches we're going to use the Angled style —choose it in the list at
the bottom. Besides, let’s change the line pattern and width.

The Line section allows to change the line properties of the branches. Make
the lines dotted (choose option 5 in the Style list) and thicker (select 4 in the
Width list).

The resulting mind map will look as the illustration on next page.

Another valuable feature of ConceptDraw MINDMAP is its support for multi-
page maps. If a mind map is too big, it's convenient to place it on several
pages. Any branch with all its sub-branches can be moved to a separate page,
as a new mind map. Both mind maps are automatically connected with hyper-
links. Such multi-page mind maps are called Multi-Map.
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Multi-page mind maps are supported only in
ConceptDraw MINDMAP Professional.

If you open a multi-map in ConceptDraw
MINDMAP Standard, it will be displayed as
usual one-page map.

To send a branch with its sub-branches to a new page, select the branch
which you want to make the central theme of the new (subordinate) mind map,
and choose the Edit -> Branch -> Send to New Page menu command. Let’s
send the Introduction branch to a new page. As the result, a new page named
Introduction will be added to the document, and the original page will change.

To go the the new page, either double-click the hyperlink Link To Page: Intro-
duction, or choose the Introduction tab in the bottom left corner of the docu-
ment window.

The symbol with the pop-up tip Link To Page: Page-1 shows that the cen-
tral theme of the mind map on the Introduction page is linked to the Page-1

page.
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The bottom line:

U You can use ConceptDraw MINDMAP for planning events such as
conferences, meetings and create visual reports about them.

U The branches of amind map can be sorted in different ways (alphabet-
ically, by priority, by number).

U The Format Map dialog allows to change various style attributes of a
mind map.

U A mind map that is too big to fit on one page can be broken down into
several mind maps, each on a separate page, connected with hyperlinks.

37




MindMap

Lesson 4. Planning a Picnic

Brainstorming. Relationship

This lesson describes the features that have been added or considerably
modified in the new version.

Besides drawing mind maps you can use ConceptDraw MINDMAP for brain-
storming.

Brainstorming was originally used to find a quick solution to a difficult prob-
lem. As a rule, several people take part in brainstorming, and the session
has a time limit. Each participant must generate as many ideas as possible,
inspired by what the others said. One shouldn’t concentrate on the logic,
instead, surrender wholly to the flow of ideas. The brainstorming mode in
ConceptDraw MINDMAP allows to organize these ideas in a hierarchical
structure.

As in brainstorming one must concentrate on ideas rather than appearance,
this technique is convenient for sketching the structure of a mind map.

Let's use brainstorming to plan a picnic. Create a new document with brain-
storming.

If the application is already running, click the
this button.

In the previous versions of ConceptDraw MINDMAP the Brainstorming win-
dow would open over the mind map document. In that window you could enter
ideas in the form of a structured list, known also as outline. The new version
also uses the outline format, but with more convenient interface. Besides, the
outline view can be used as an alternative to the diagram view.

You can use the Outline View button (or press
F3) to toggle between these two modes.

If you want to limit the time for the discussion, enter the time in the Hours,
Minutes, Seconds fields and click the Timer On/Off  button to start the
timer. When the time is up, a message will be displayed.

When creating a new document with brainstorming a new document will open
in the outline view.
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As in any new document, a blank document in the brainstorming mode al-
ready contains the central theme. You can edit its text immediately. We'll re-
name the central theme to Picnic. To quit the text editing mode, press Enter or
click outside the text box. To modify text of an outline item, double-click the
item to enter the editing mode.

The following tools are used to add new items to the outline: Add Topic and
Add Subtopic.

Add Topic adds a new item to the outline on the same level as the previous
one. Add Subtopic adds an item that is one level lower («child»). You can
also use the keyboard to add items — Enter does the same as Add Topic,
Shift+Enter is equivalent to Add Subtopic. As a mind map can have only
one central theme, when the central theme is selected, both Enter (or Add
Topic) and Shift+Enter (or Add Subtopic) add an item a level lower.

Let's try on an example. Start discussing what is needed for a picnic. First of
all, determine how many people are going. To add the Participants Number
topic, make sure the central theme is selected (has a dashed border around
it), and press Shift+Enter (or Enter). A new item will be added to the outline.
It's automatically named New Branch. This item is offset slightly to the right,
demonstrating that it's subordinate to the central theme (in the mind map view
New Branch will be connected to the central theme). The text of the new item
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becomes selected so you can edit it right away. Rename the item to Partici-
pants Number and press Enter to quit the editing mode.

Then think how to get to the picnic area— add the Getting there topic. To insert
a new item, just press Enter. Here it doesn’t matter which of the items are
selected —the new item will be added on the same level as Participants Number.

Develop this topic, adding a couple ideas on how to get to the place. For in-
stance, the participants can go by car or rent a bus. As these ideas belong to
the Getting There topic, make them subordinate to it. Make sure Getting There
is selected and press Shift+Enter to create a subordinate item one level be-
low. Name it Cars and press Enter to quit the text editing mode.

Cars is now selected. To add a new item on the same level, press Enter and
type Rent a bus.

Leave this topic for now, and pass to a new one. Think about entertainment.
Add the Entertainment topic on the same level as Participants Number and
Getting There. As now the Rent a bus topic is selected, pressing Enter will
add a new item on the same level, which is not what we want. To insert the
Entertainment topic on the needed level, do one of the following:
1. Select the central theme, Picnic, and add a subordinate topic
(press Enter or Shift+Enter). The first-level item will be added
to the end of the list, as needed.
2. Select Getting There and add a new topic on the same level
(press Enter).
3. With Rent a bus selected, add a topic on the same (second)
level (press Enter). Then use the Outdent tool to move it one
level higher.
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Go on adding new items to the outline until it looks same as on the illustra-
tion below. Select the needed topics in the list and add new ones on the
same or lower level. You can use the following buttons: Indent (Ctrl (Cmd) +
right arrow) and Outdent (Ctrl (Cmd) + left arrow ) to modify the level of
the item, and Move To Previous Position (Ctrl (Cmd) + up arrow ) and
Move To Next Position (Ctrl (Cmd) + down arrow ) to move the topics up
and down inside the list. To delete an item, select it and press the Remove
Topic button (Delete).

If you get back to the mind map view, you'll see a traditional mind map.
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To go back to the outline view click the
Outline View button.

It offers additional options — same as in the mind map view, you can add text
notes and symbols to comment ideas. There are three columns to the left of
the main area: T — for text notes, H — for hyperlinks, and Symbols — for sym-
bols. You can add a comment or link same as in the mind map view. For in-
stance, to add the Important ~ symbol to Getting There, select the topic and
click on the appropriate symbol on the symbol panel.

Add a text comment regarding the tape recorder.

Select the Tape Recorder topic and click the
Edit Text Note button.

The Edit Text Note pane will appear at the bottom of the window. Type the
following text init:  Jack takes his one;
Ann and Bob can take records
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In the T column opposite the Tape Recorder item the text note icon  will ap-
pear. If you pause the mouse over the icon, the text of the comment will pop up.

Add symbols and text notes to other topics of the outline. The result should
look as follows:
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and the corresponding mind map — as shown here:

The outline view doesn’t allow to choose the level of detail, however, it allows
to expand or collapse the subtopics of each topic. Each topic that has children
displaysa  symbol near it. Click it to hide all the subtopics of the topic. The
symbol will change to . Click it again to expand the topic.

Collapsing or expanding topics does not affect the diagram view of the mind
map, and vice versa.

You can also sort topics in the outline view, same as in the mind map view. For
details on how to do it, see Lesson 3.

A mind map represents ideas, facts and objects as a hierarchy — ideas are
organized from the general to the particular. However, the real life is not al-
ways so logical, and two concepts can be related even if one doesn't follow
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the other. For instance, there are food, medicines and alcoholic drinks. They
aren’trelated on the mind map, though they may be related in the real life (one
may need a medicine after drinking too much alcohol). You can show this
relationship graphically in ConceptDraw MINDMAP.

ConceptDraw MINDMAP 3 contains a new
tool — Insert Relationship.

It allows to connect two branches with a thick dashed line. To connect the
branches, click the Insert Relationship button. When you move the mouse to
a branch, its text is highlighted with green. Click and hold down the mouse
button and drag the mouse to the branch you wish to connect to the first one.
A dashed line will follow the pointer. Move the mouse to the branch so that its
text is marked with green, and release the mouse button. The two branches
are now connected, and the connection will be kept even if you reposition the
branches. To change the form of the connecting line, use the adjustment han-
dles on it.
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Note: You can only insert relationship in the mind map view. Relationships are
not reflected in the outline view.

In the result, the mind map will look as follows:

Decorate the mind map with images and styles. Here is the final variant:

The picture for the central theme was taken from the Symbols4 library. Note,
that you can change the line color and pattern of the relationship line same as
for any other object on the mind map.
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The bottom line:

U ConceptDraw MINDMAP allows to use brainstorming as a companion
technique to mind mapping.

U A separate Outline View is used for brainstorming.

U Inthe Outline View it's easy to edit the structure of the mind map, add
symbols and text notes, assign hyperlinks.

U Both the mind map and outline views allow to hide or display elements
of the mind map structure, and change the level of detail. Thanks to this
you can present the document in a more or less detailed form. Changing
the level of detail works differently in the mind map and outline views.

U0 ConceptDraw MINDMAP lets you show visual relationship between
topics on the map.

Lesson 5. Additional Capabilities Of
ConceptDraw MINDMAP

Drawing. Editing objects. Operationson objects.
Textin a mind map

Now you are familiar with all main features of ConceptDraw MINDMAP, and you
have enough knowledge to create most varied and impressive mind maps. But
of course there are some aspects which haven't yet been covered. In the previ-
ous lessons the attention was paid to the features, specific to mind maps — such
as changing the structure of the map, adding symbols, hyperlinks, using the
Brainstorm mode. In the last lesson of this tutorial you'll get acquainted with the
drawing capabilities of ConceptDraw MINDMAP. You can use it as a graphics
editor, and decorate your mind maps with simple drawings.

This lesson has a different structure than the previous ones. It describes a vari-
ety of different tools used for the similar purpose, so we won’t describe creating
a certain mind map, rather will give some tips on how to use these tools.

1. Inserting Pictures

The easiest way to add impact to your mind map is to use ready-made images
in graphic files on your computer. They can be attached to branches or used
separately — for instance, as the background.
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To insert a picture from a file, choose the Insert -> Picture menu command.
The File Open dialog will come up, allowing to locate and choose the desired
graphicfile.

It's even easier to use the Clipboard to add a picture to your mind map. If the
picture is in a document (for instance, in a MS Word document), copy it from
there, then switch into ConceptDraw MINDMAP and press Ctrl+V (Cmd+V).
The picture will be inserted into the mind map.

A slightly different way is used to insert an image for the central theme of a
mind map.

d- Select the central theme.

d- From the context menu (or from the Format menu of the application)
choose the Change Central Theme Image command.
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d- Inthe Central Theme dialog click on the Select an image from another
source button.

d- The file dialog will come up. Navigate to the needed file, select it and
click OK.

2. Drawing Tools
In ConceptDraw MINDMAP you can draw yourself by using the
built-in drawing tools. On the Drawing Tools toolbar there is a pull-
down list of drawing tools. In Lesson 1 we used it to draw a rectan-
gle and an ellipse.

To draw a rectangle:

d- Choose the Rectangle tool.

d- Press and hold down the mouse button where you want the left
top corner of the rectangle to be.

d- With the mouse button held down, drag the pointer to the place where
you want the bottom right corner of the rectangle to be, and release the
mouse button.

To draw an ellipse:

d0- Choose the Ellipse tool.

d- Draw same as you drew the rectangle. The ellipse will appear inside its
alignment box.
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There are tools which you can use to draw more complex objects, that contain
several segments. A segment is a line, arc, sector or a spline segment.

Let's draw an object made up of several segments — a drop. It will contain
three segments — two lines and an arc.

0- First, draw a line using the LineTo tool. Start drawing from the bottom
end and up.

d- With the first segment selected, draw another one, starting from the
upper end of the first segment.

d- Choose the ArcTo tool and draw an arc that connects the ends of the
two segments and closes the figure. If needed, use the adjustment
handle in the center of the arc to correct its form.

Now let’s draw a styled sail, made up of three ellipse segments. Use the EI-
lipseTo tool to draw the ellipse segments.

d- Draw the first segment (bottom-up).
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From its end point draw another segment, ending slightly higher than
the first one.

Close the figure with the third segment.

On our picture the third segment is concave down. To make it concave
up, use the adjustment handles to change its form and direction.

Lesson 5

And finally, let’s see how the Spline tool can be used.

This tool is used for freeform drawing and behaves similar to a pen on paper.
We'll use it to encircle a group of branches.

o
o

Choose the Spline tool.

Click somewhere on the map and with the mouse button held down,
drag to draw the line. The black line will follow the pointer, showing how
the spline will be drawn.

When done drawing, release the mouse button. As you can see on the
illustration to the right, the resulting object is made up of humerous
segments. The adjustment handles on the segment allow you to change
their form.

Use the adjustment handles to correct the form of the spline.

Change the color and width of the line.
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3. Editing

As it’s quite unlikely that you'll draw everything correctly from the first try, and
graphic editor allows you to edit your drawings.

In the previous paragraph we showed how to change the form of segments by
using their adjustment handles. Now we’ll demonstrate other ways of editing
objects.

Repositioning
You can reposition any object by dragging it with the mouse. A box that ap-
pears when you're dragging the object shows its size and current position.

Resizing

Objects can be resized. To resize an object, select it and drag one of the
corner handles on its alignment box. To resize only one side of the object,
drag the handle in the middle of that side.
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Rotating

To rotate objects the Rotate tool is used.

It can be found in the same pull-down as the
Select tool.

When the Rotate tool is active, the handles in the corners of the alignment
box change their form to round. When you drag such handle, the object is
rotated. The handle in the center of the object controls the rotation center
position.

To continue editing don’t forget to switch back to the Select tool.
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Flipping
To flip a selected object:

0. horizontally — press Ctrl+H (Cmd+Opt+H) or select the Figure -> Flip
Horizontally menu command from the application or context menu.

d- vertically — Ctrl+J (Cmd+J) or Figure -> Flip Vertically.

4. Groups
Sometimes it's convenient to work with several objects as with a single object:
reposition, rotate around the common center, resize or flip.

For this purpose you can group several objects together. A group contains
several objects, but behaves as one. You can ungroup it anytime to bring back
the objects it's made up of.

To group several objects, select them (hold down the Shift key to select more
than one object) and press Ctrl+G (Cmd+G) or choose the Figure ->
Group.menu command.

To ungroup, press Ctrl+U (Cmd+U) or use the Figure -> Ungroup command.

Note, that you can only group stand-alone objects. You can’t group the central
idea, a branch or an object attached to a branch with other objects.
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5. Text
In ConceptDraw MINDMAP you can insert stand-alone text into a diagram. To
do this, use the TextBox tool on the Drawing Tools toolbar.

o}
o}
o}
o}

- Select this tool.
- Draw a box which will enclose the text.
- Input the text.

- Click away from the text box.

Lesson 5

The text object is ready. It's the same object as any other — you can select is
with the Select tool, rotate, resize, etc.

For more information about the drawing tools and other functionality of Con-
ceptDraw MINDMAP refer to the ConceptDraw MINDMAP Help System.

The bottom line:

i

To make drawing mind maps more flexible, ConceptDraw MINDMAP
includes some features of a vector graphics editor.

You can insert images from graphic files or the Clipboard.
Inserting a central theme image is different from inserting any other image.

In ConceptDraw MINDMAP you can draw simple objects (such as a
rectangle or ellipse), or complex objects made up of different segments
—lines, arcs, sectors and spline segments.

Objects can be edited: repositioned, resized, rotated, flipped.

Two or more objects can be grouped together. A group behaves as a
single object.

You can insert stand-alone text in the mind map.
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